Versie geschiedenis

Overzicht van wijzigingen in de verschillende versies van de BRCadV7 applicatie. Dit overzicht is ook te raadplegen via httpswiki.brcontrols.com ————————————————————————————————————— ### 7.1.0.0 Uitgebracht (29-09-2026) #### Toevoegingen - Options - Op de General tab is er een folder selectie bij gekomen, hiermee kan geselecteerd worden of de Documents of Program Files opslag gebruikt wordt. - User setting - Opslag van de folder selectie, deze blijft bekend. - Library - Wordt opgeslagen met het de complete folder, hierdoor kunnen ook libraries opgeslagen worden die niet in de library folder staan. - Picture - Als er tijdens het aanpassen van een plaatje een andere folder geselecteerd wordt, zal de volgende keer tijdens editen van een Image (openen of opslaan) beginnen in dezelfde folder. - Update Blokkering - Als de applicatie draait vanuit de Program Files (x86) folder kan na deze update niet meer geupdate worden, hiervoor is een nieuwe installatie nodig. Noodzakelijk voor draaien zonder Administrator rechten. #### Aanpassingen - Library - Weergave van libraries heeft nu onderscheid tussen Libraries uit de Librarie folder, en extern Libraries. - Folders - Folder structuur is aangepast, libraries en de BR_CadV7.ini kunnen ook benaderd worden vanuit AppData/Roaming. - Menu - Menu folder wordt gekopieerd naar de Roaming folder. #### Opgelost - ProjectWizard - Ok knop niet beschikbaar bij aanmaken nieuw project, nadat er eerder een project open heeft gestaan. - CrossRef / Export - Values (waaronder Units) kunnen nu maximaal 512 characters bevatten, niet meer 150 ————————————————————————————————————— ### 7.0.8.1 Uitgebracht (14-01-2026) #### Toevoegingen - Import BrSelect/BrTagBuilder - Lijst toegevoegd die de missende TagName punten toont, en de mogelijke vervanging voor de punten. - Import BrSelect/BrTagBuilder - Remove knop toegevoegd, hiermee kunnen de missende TagNames verwijderd worden in de CrossRef weergave, deze moeten met de hand weer gekoppeld worden. - Import BrSelect/BrTagBuilder - Hide unused tagnames checkbox toegevoegd, hiermee kunnen de niet toegepaste tagnames verborgen worden in de verwijder lijst. - Import BrSelect/BrTagBuilder - Popup menu toegevoegd, vergelijkbaar met de replace popup, met alles selecteren en alles deselecteren. - IoData - Bij Plakken van Bestemming veld, springt de selectie niet meer naar de eerste colomn. - Options - Show Tagname expanded checkbox toegevoegd, als deze aanstaat wordt de TagName selector altijd automatische uitgeklapt. - Options - Hide when done, hiermee kan de parameter standaard op Checked of Unchecked gezet worden. #### Opgelost - IoData - Bij aanpassing van een Bestemming veld werdt er een index out of bound melding gegooit, dit is verholpen. - IoData - Bij verwijderen van de visible tekst (delete), werdt 1 karakter teveel verwijderd achter het geselecteerde deel, dit is verholpen. - IoData - Bij invullen van de Io_Index waarde wordt de detectie van tagnames pas gestart bij verlaten van veld of met enter. - IoData - Scherm is breder gemaakt waardoor de velden minder snel verspringen bij aanpassingen. - TagName Selector - Enter triggert niet automatische de Replace knop - CrossRef - TagName veld blijft nu ook voor een Type DI en Index hoger als 1023 en ComboBox. - CrossRef - TagName veld wordt niet rood als er een Type DI en Index onbekend boven de 1023 geselecteerd is. ————————————————————————————————————— ### 7.0.8.0 Uitgebracht 17-11-2025 #### Toevoegingen - Project - Aanpassen van de Scheme names heeft nu een character check een aantal characters zijn uitgesloten voor de Scheme name - Project - Scheme hernoemen heeft verbeterde naam validatie - Project - Scheme aanmaken heeft verbeterde naam validatie - Export - Tijdens navigeren naar de Export tab, is het niet meer mogelijk om bepaalde Shortcut toetsencombinaties uit te voeren, dit ter bevordering van navigatie binnen de applicatie - Copy / Paste - Niet meer mogelijk tijdens opslaan van projecten. - Export - Als na het automatische opslaan van projecten nog steeds wijzigingen beschikbaar zijn wordt er terug genavigeerd naar de Project weergave. - Scheme Rename - Hernoemen van Scheme's werkt ook zonder prefix om te vervangen, als dit niet ingevuld wordt dan wordt de replacement tekst toegevoegd voor de Scheme naam. #### Opgelost - SchemaUpload - BRC45 met firmware versie lager als 583 hebben de automatische selectie voor MMC en RAM weer aanstaan. - Main - Meer controlle toegevoegd op valide objecten. ————————————————————————————————————— ### 7.0.6.5 Uitgebracht op 07-10-2025 #### Toevoegingen - IoData - Afhandeling tussen parameters van de Details weergaven in de IoData en de CrossRef verbeterd, dit werdt niet altijd goed geupdate als er aanpassingen waren - TagNameSelector - Expand all functie toegevoegd, deze is toegevoegd aan het popup menu (rechter muis knop) en tevens gekoppeld aan Alt+Right (pijltjes) - TagNameSelector - Collapse all functie toegevoegd, deze is toegevoegd aan het popup menu (rechter muis knop) en tevens gekoppeld aan Alt+Left (pijltjes) - TagNameSelector - Automatische selecteren van hoofdnode als er een subnode geselecteerd wordt (bij deselectie van subnode wordt de hoofdnode ok gedeselecteerd) - TagNameSelector - Als de Hoofdnode gedeselecteerd wordt, worden geselecteerd subnodes ook gedeselecteerd - ProjectTree - Expand all en Collapse all gekoppeld aan Alt+Right en Alt+Left - CrossRef - Tijdens aanpassen van de Controller wordt de Hint tekst niet meer verwijderd - CrossRef - Tijdens Controller aanpassing van Invalid naar een valide controller zal de BRN_ID niet mee geupdate worden naar de controller naam - ExportScheme - Checkbox toegevoegd (rechts midden), om de Hint teksten niet mee te exporteren naar de BRT bestanden #### Opgelost - IoData - Hier kan nu ook 220 Text object geselecteerd worden, de logica is aangepast om de specifieke parameters aan te kunnen - ImportScheme - Tijdens het importeren van extern schema's wordt de MenuItem lijst niet meer leeg gehaald ————————————————————————————————————— ### 7.0.6.4 Uitgebracht op 14-05-2025 #### Toevoegingen - TagName - Weergave van de TagName koppelingen werdt niet geupdate na het knippen van objecten in de scheme - Export Upload - Bestanden die toegevoegd worden aan het zip bestand worden vrijgegeven - Export Scheme - html_data doc invul veld is verborgen, deze logica zit nu in de WebService. - Export Upload - html_data doc wordt verborgen als de feature uitstaat. - IoData - Afhandeling tussen parameters van de Details weergaven in de IoData en de CrossRef verbeterd, dit werdt niet altijd goed geupdate als er aanpassingen waren - ExportScheme - Checkbox toegevoegd (rechts midden), om de Hint teksten niet mee te exporteren naar de BRT bestanden #### Opgelost - Library - Library open en nieuwe librarie aanmaken worden geblokkeerd tijdens het opslaan van een project - Export Scheme - html image folder “../img” wordt niet meer standaard aangemaakt - Export Upload - html image folder “../img” wordt niet toegevoegd als deze niet bestaat op de schijf - IoData - Hier kan nu ook 220 Text object geselecteerd worden, de logica is aangepast om de specifieke parameters aan te kunnen ————————————————————————————————————— ### 7.0.6.0 Uitgebracht op 14-05-2025 #### Toevoegingen - TagName selector - Tijdens het aanpassen van een LCSCD Io_Type zal de DecPos parameter geupdate worden naar de benodigde waarde (0 of 2). - CrossRef - Tijdens selectie van een andere Io_Idx voor een LCSCD Io_Type zal de DecPos parameter geupdate worden naar de benodigde waarde (0 of 2). - CrossRef - De BRN_ID parameter kan nu ook getoont worden in de CrossRef main weergave, kan tevens getoont worden in de details. - Export - Scheme export heeft een checkbox, deze zorgt ervoor dat de Export vlag in de V5 en oudere projecten genegeerd wordt. - ProjectBuilder - Na aanmaken van een nieuw project doormiddel van de ProjectBuilder, is het mogelijk om de applicatie te sluiten. - Import - Als een bestaand project openstaat, en hiervoor een Import gedaan wordt vanuit TagBuilder of Select, kan nu de aangepaste Regelaar volgorde toegepast worden. - TagName - Weergave van de TagName koppelingen werdt niet geupdate na het knippen van objecten in de scheme - Export Upload - Bestanden die toegevoegd worden aan het zip bestand worden vrijgegeven - Export Scheme - html_data doc invul veld is verborgen, deze logica zit nu in de WebService. - Export Upload - html_data doc wordt verborgen als de feature uitstaat. #### Opgelost - Export - Tijdens exporteren wordt er voor BRC23 en BRC45 regelaars gevraagd of de HTML files gekopieerd moeten worden naar RAM, deze functie werkt nu weer zoals verwacht. - Export - Tijdens uploaden zal in de te uploaden bestanden boom de Ram gesloten en niet geselecteerd zijn. - Export - Tijdens uploaden is het mogelijk om los bestanden voor de Ram opslag te selecteren (dit zal er wel voor zorgen dat de HTML kopie naar RAM niet getriggerd wordt). - Project - Opslaan van project wordt nu geblokkeerd als er een project opgeslagen wordt. Er wordt in het midden een dialoog getoont dat het opslaan al actief is. - Project - Na het opslaan van een project wordt een Dialoog getoont dat het project opgeslagen is. - Project - Tijdens opslaan van projecten worden de andere acties geblokkeerd, zoals knippen, plakken en dupliceren. - Project - Slepen van Scheme naar Tile Scheme werkt weer. - Project - Preview tonen wordt geblokkeerd tijdens het opslaan van een Project. - Project - Na sluiten project wordt de Applicatie title geupdate. - Scheme - Kopieren naar ander scheme blokkeerd af en toe, dit is nu weer mogelijk - Scheme - Na kopieren van verschillende Flex objecten kan het voorkomen dat er een blanco regel toegevoegd wordt aan de CrossRef tabel (TFlexMarker) veroorzaakte dit. - Scheme - Kopieren naar een ander scheme blokkeerd de Knippen, Plakken, Verwijderen en Kopieren niet meer, tevens is het niet nodig dat de cursor binnen het Scheme deel staat. - Scheme - Dubbel klik op een plaatje zonder IoData opent nu de PictureIdx editor. Voor heen opende dit niks. - Scheme - Plakken uitgebreid met Ctrl + Alt + V, deze versie zal de CtrlGuid van het IO_Data punt behouden. Deze werkt naast de standaard Plakken Ctrl + V. - Scheme - Dupliceren uitgebreid met Ctrl + Alt + D, deze versie zal de CtrlGuid van het IO_Data punt behouden. Deze werkt naast de standaard Plakken Ctrl + D. - Scheme - Alignment functies hebben twee snelkoppeling gekregen Ctrl + Alt + letter (zie popup menu), en Numpad keys zie documentatie. - CrossRef - Bij selectie van meerdere objecten wordt de Crossref geupdate naar de eerste geselecteerde regel, hiervoor is onder de popup nu een check optie toegevoegd om dit wel te doen. - CrossRef - Bij het toevoegen van IoData aan een scheme die nog geen IoData heeft blijft de headerbalk (parameter namen) staan. - CrossRef - Oplossing van foutmelding voor multi selectie in de Scheme, deze kon in enkele gevallen een grid index out of bounds opleveren. - Options - Options dialoog is nu schaalbaar, en alle paginas bevatten vertical scroll opties zowel balk als muis scroll. - ProjectWizard - Ok knop is weer beschikbaar bij regelaars binnen een Project. - Library - Library maakt nu alleen gebruik van het aangeboden ActiveFlex object (niet meer van de Frame_Child parameter). - Library - Library open en nieuwe librarie aanmaken worden geblokkeerd tijdens het opslaan van een project - Export Scheme - html image folder “../img” wordt niet meer standaard aangemaakt - Export Upload - html image folder “../img” wordt niet toegevoegd als deze niet bestaat op de schijf #### Aanpassingen - Export - Melding toegevoegd voor als te exporteren bestanden niet toegangkelijk zijn. - IoData - Form wordt nu lager getoond net onder de navigatie balk. - IoData - Form kan nu via de Options→General settings ingesteld worden om op een andere plek getoont te worden. - IoData - Form gebruikt nu Parameters uit de User.ini file om te bepalen waar die getoont kan worden. - Options - General settings tab uitgebreid met Left en Top parameter (4, 106) en een Reset knop voor de plaats bepaling van de IoDataForm. - PictureIdx - Na laden en opslaan wordt de PictureIdx weer naar de voorgrond gebracht. ————————————————————————————————————— ### 7.0.4.3 Uitgebracht op 06-02-2025 #### Toevoegingen - Export - Voor knoppen, met een Text veld is het niet perse nodig om de “naam[naam]” meer door te geven, deze wordt automatisch toegevoegd bij export. - IoData - Dialoog gemaakt voor het editen / bewerken van de IoData (vergelijkbare parameters met de CrossRef tabel). #### Aanpassingen - Scheme - Edit tools in voor de Scheme worden gelocked als in de Layers 1 van de opties uit staat. - Export - Optimalisatie tijdens het openen van de Export view, dit was traag door de Alarmen en Goto bepaling. #### Opgelost - Layers - Als er een layer geselecteerd is die waarvan 1 optie uit staat zal de Scheme editing vervallen. - Export - Detectie en beveiliging ingebouwd, tegen bestanden die niet benaderd en aangepast kunnen worden, hierbij zal een Dialoog getoont worden met opties. - Export - 42 - Button of Label export oplossing, hierbij werd het bedienniveau meegegeven inplaats van de text. - Project - Laden van projecten verbeterd, hierbij is het nu weer mogelijk om achtergronden op de Scheme's te zetten. ————————————————————————————————————— ### 7.0.4.2 #### Toevoegingen - Scheme - Na duplicatie van objecten wordt de IoDataForm niet geupdate. ————————————————————————————————————— ### 7.0.4.1 #### Toevoegingen - CrossRef - Veld Bestemming als deze in de details getoont wordt, dan wordt de Scheme name selectie niet goed geladen. ————————————————————————————————————— ### 7.0.4.0 #### Toevoegingen - TagNames - Filter toegevoegd voor het filteren van niet gebruikte tagnames. - ExportScheme - Subset selectie van Schemes wordt meegenomen naar UploadScheme. - Library - Drag en Drop naar Scheme geeft geen foutmelding meer. - Scheme - Preview bij inslepen library item wordt getoont. - Export - De export naar BRT zal nu Name velden aanvullen als deze geen [] bevat. - ProjectBool - Bij herselectie van een al geselecteerd scheme in de boom, zal in de Inspector het eerste (scheme) element getoont worden. - ExportScheme - Controle en Melding als bestanden al in gebruik zijn door andere applicaties. - ImportScheme - Postfix “_1” veranderd naar Prefix “1_”, voor makelijker gebruik binnen Scheme rename. - Scheme - Popup menu heeft de opties voor tonen van de Edit text, Edit picture, Edit IoData. #### Opgelost - Menu - Toont het reopen venster niet als deze niet geselecteerd is. - Export - Optimalisatie tijdens exporteren grote projecten (Scannen voor Controllers verbeterd). - CrossRef - Lijst met Tagnames wordt nu op de orginele volgorde weergegeven, zonder Filtering of Sorting van TagNames. - TagName Selector - Lijst met Tagnames wordt nu op de orginele volgorde weergegeven, zonder Filtering of Sorting van TagNames. - Inspector - Uitschakeling van Transparensy parameter, dit werdt wel getoont in BrCad maar niet netjes meegenomen in de Export. - Import - Na importeren van velden uit Select of TagBuilder wordt de Tagnames lijst gesorteerd. - CrossRef - Io_Index wordt niet meer verwijderd bij selectie. #### Aanpassingen - TagNames - Filtering wordt anders afgehandeld. - CrossRef - BedienNiveau wordt nu gevalideerd, aan de hand van de beschikbare lijst. - CrossRef - Validatie van verschillende velden is aangepast. - CrossRef - Selectie van TagNames & IoIndex aangepast, de gehele lijst met opties vanuit de tagnames wordt getoont. - Options - Selectie toegevoegd in General Tab, CrossRef op de voorgrond houden of bij selectie naar voorgrond brengen. - Options - Selectie toegevoegd in General Tab, IoData op de voorgrond houden of bij selectie naar voorgrond brengen. - Options - Selectie toegevoegd in General Tab, Om het IoData scherm wel of niet te tonen naar Dubbel klik op een object. ————————————————————————————————————— ### 7.0.2 Uitgebracht op 24-09-2024 #### Opgelost - Export - BRN20 export aanpassing, ID veld wordt nu toegevoegd aan de BRT export (vanuit de CrossRef data). ————————————————————————————————————— ### 7.0.1.1 Uitgebracht op 24-09-2024 #### Opgelost - Export - BRN20 export aanpassing, ID veld wordt nu toegevoegd aan de BRT export (vanuit de CrossRef data). ————————————————————————————————————— ### 7.0.1 #### Opgelost - Initiale release van BrCad V7. - Nieuwe installer gemaakt. ————————————————————————————————————— ### 7.0.0.13 Uitgebracht op 22-08-2024 #### Toevoegingen - CrossRef - Details worden nu allemaal weergegeven, ook als maar 1 colomn getoont kan worden. #### Opgelost - Options - Options dialoog is kwa stijl gelijker gemaakt aan de standaard. ————————————————————————————————————— ### 7.0.0.12 Uitgebracht op 01-08-2024 #### Toevoegingen - CrossRef - Kolommen Selection en State kunnen niet aangepast worden op breedte. #### Opgelost - CrossRef - Bestemming en Units worden opgeslagen (herstel van de filter logica). - CrossRef - All benodigde kolommen worden weergegeven in asgDetails. ————————————————————————————————————— ### 7.0.0.11 Uitgebracht op 31-07-2024 #### Toevoegingen - CrossRef - Kolommen kunnen door te slepen op een vaste breedte gezet worden (dit wordt per gebruiker opgeslagen) - CrossRef - Popup menu heeft een extra optie Reset grid column size, hiermee kunnen de boven ingestelde breedtes gereset worden. - Project - De project boom validatie kan aan en uit gezet worden via de Project - Scheme Validation #### Aanpassingen - CrossRef - Afhandeling verlaten CrossRef naar andere scherm elementen verbeterd, hierbij werdt niet in alle situaties het editen van velden beeindigd. #### Opgelost - CrossRef - Duplicaat asg verwijderd uit de CrossRef. ————————————————————————————————————— ### 7.0.0.10 Uitgebracht op 19-07-2024 #### Toevoegingen - CLI opties toegevoegd aan opstart gedrag applicatie - Picture edit - Venster aangepast, houdt nu beter rekening met Mask / Transparent opties voor geladen plaatjes. - Rename Scheme (nieuw) - Venster waarin voor Controllers meerdere Schemes in een keer aangepast kunnen worden. #### Aanpassingen - Aanmaken Project heeft geen Postcode meer nodig om aangemaakt te worden. - Aanmaken Project is het Address veld niet meer verplicht. - Applicaties houdt rekening met aanwezigheid BrSelect / BrTagbuilder voor de tekstuele knoppen. - Project tree - popup menu opties aangepast voor situatie zonder geopende project. - CrossRef - Weergave van Bestemming veld toont geen duplicaat Scheme namen meer. - Project tree - popup menu heeft voor GlobalSchemes de optie om Schemes te importen uit bestand. #### Opgelost - CrossRef - Veranderen van Controller update velden nu direct (zonder te moeten schakelen tussen Schemes) - CrossRef - Veranderen van Menu (Project Tree scheme selectie, Export, Logging) afhandeling van velden die nog bewerkt worden aangepast. - CrossRef - Veld validatie wordt alleen gedaan op aanwezige regels - Design menu - Mouse cursor enable mouse wheel zoom werkt zoals omschreven - Export - ControllerId correctie aangepast deze gaf een foutmelding als er geen Controller ingevuld is. ————————————————————————————————————— ### 7.0.0.9 Uitgebracht op 05-07-2024 #### Toevoegingen - Aanmaken Scheme binnen GlobalSchemes prefix aangepast van “_GlobalSchemes_” naar “GS_” - Importeren naar GlobalSchemes vanuit een BrCad project bestand mogelijk gemaakt - Applicatie opstart parameters toegevoegd (worden gecontroleerd bij opstarten applicatie) #### Aanpassingen - Limitatie toegepast op Controller namen, deze mogen niet gelijk zijn aan bestaande namen, en mogen niet gelijk zijn aan “_GlobalSchemes” - Tijdens aanpassen Pictures “Edit Picture”, geeft nu bij alle verschillende plaatjes types de mask / transparent kleur selectie - Hoofd node in de project boom kan niet meer verwijderd worden - Tijdens selectie van Bestemming in de CrossRef (voor GlobalSchemes), worden nu de GlobalSchemes paginas niet dubbel getoont - Layers tab naar boven en naar beneden knoppen werken weer naar behoren - Als er bij sluiten van een project de Export tab open staat wordt er terug genavigeerd naar de Design tab #### Opgelost - GlobalSchemes Io_Type gelimiteerd tot “DI” en “WORK” - GlobalSchemes Io_Type “DI” moet een Io_Index hoger als 1023 hebben - GlobalSchemes Io_Type “WORK” moet een Io_Index hebben (0 of hoger) - Printen van Schemes wordt nu in 1 opdracht of 1 bestand gedaan, in plaats van 1 per scheme - Afsluiten applicatie na aanmaken nieuw project zonder deze op de schijf op te slaan geeft geen foutmelding meer - Verwijderen logging in de Logging pagina is niet meer mogelijk ————————————————————————————————————— ### 7.0.0.8 Uitgebracht op 13-06-2024 #### Toevoegingen - Indicatie voor communicatie met regelaars aangepast hierbij wordt nu IP, Port en Protocol weergegeven als de regelaar niet bereikbaar is. #### Opgelost - Voor exporteren naar BRT bestanden de volgorde aangepast zodat het 'Width' veld voor TFlexText42 (Label buttons), de Inspector 'Width' gebruikt boven de CrossRef 'Width'. ————————————————————————————————————— ### 7.0.0.7 Uitgebracht op 11-06-2024 #### Toevoegingen - Project Rename kan nu ook geopend worden door de sneltoets 'F2'. - Aan het Tagname selector scherm is een checkbox toegevoegd om IO punten zonder Tagname of Alias te verbergen. - Tagname selector filtering kan nu gestart worden na 'tab', 'enter' of verlaten van filterveld. - Tagname selector filtering werkt niet meer op basis van 1 seconde na laatste invoer starten met filteren. #### Aanpassingen - Tagname selector scherm heeft een andere layout. - Crossref Details afhandeling voor enkele velden aangepast, 'enter' toont niet weer dezelfde lijst, zoals voor de 'BRN_ID'. - Logging pagina heeft nu een Scrollbalk voor snellere navigatie. - Properties optie in het Project popup dialoog tonen voor Scheme, en SchemeGrids weer de benodigde property schermen. - Project popup menu zet export uit voor project niveau. - Multy copy scherm, terug gezet naar weergave zoals V6.2.4 het toont. - Help knop in bovenbalk tijdelijk uitgeschakeld. - Logicad.csv knop in bovenbalk tijdelijk uitgeschakeld. #### Opgelost - Tijdens controle van bestanden voor het SchemeUpload scherm wordt de vorige teller voor missende bestanden niet op 0 gezet, hierdoor werdt elke opvolgende keer de Popup getoont dat er bestanden missen in het project. - Inladen Project bestanden onafhankelijk gemaakt van Project opslag volgorde, dit veroorzaakt de melding “is Not a valie BrCad project file”. - Project Delete actie (delete knop), gebruikt het geselecteerd object in de Project boom, dit wordt niet meer gedaan op basis van de muis positie. - Tagname selector filtering is aangepast, er kan gebruikt gemaakt worden van een '' om meerdere teksten in te vullen om op te filteren (bijvoorbeeld “AlgemeenBrand”). - Bij tonen van CrossRef table of Tagname selector schermen, wordt de TagName tab gebruikt als input. Hiervoor werden de LC_Tagname en Tagname bepaald aan de hand van de dichtklapbare lijsten, deze maken nu gebruik van de totale lijst. - Achtergrond kleur hersteld voor Tiles / grid pagina wanneer deze aangemaakt worden. ————————————————————————————————————— ### 7.0.0.6 Uitgebracht op 28-05-2024 #### Toevoegingen - Title in de Navigatiebalk aangepast worden geen *** meer aan toegevoegd - BRN_ID in Crossref details is weer editbaar zonder foutmelding - Floorplan kan geexporteerd worden door de Layer of Visible te zetten - Nieuw Demo_Project toegevoegd aan de Install files #### Opgelost - Editbaar zorgt er niet meer voor dat plaatjes verdwijnen in de scheme weergave - Laden van de Libraries verbeterd, als er te veel +40 libraries geladen werden kwam er een out of memory foutmelding ————————————————————————————————————— ### 7.0.0.5 Uitgebracht op 23-05-2024 #### Toevoegingen - Aanmaken nieuwe library wordt nu met de ingave van 'Node text' zonder 'Library filename' opgeslagen als <Note text>.fxl - Weergave en afhandeling van 'Text' in de CrossReference Details update de text in het scheme. - Weergave en afhandeling van 'Bestemming' in de CrossReference Details toont nu de Dropdown met mogelijk scheme'samengevoegd - Tagname Selector aangepast zodat er meer opties zijn voor het Selecteren van datapunten, zoeken op Alias veld toegevoegd. #### Opgelost - Toevoeging gedaan aan de informatie in de fout afhandeling (MadExcept Mail) - Aanpassen van Regelaar naam via de Regelaar Properties uitgeschakeld, deze informatie kan ontvangen worden uit 'BrSelect' or 'BrTagBuilder' - Volgorde van Regelaars in project bestand aangepast, niet meer op basis van toevoeging. Hier wordt nu een lijst voor gebruikt. - Laden Project filtering op Regelaar namen verruimt, regelaars met een '.' in de naam werden niet goed geladen. - Slepen van Library objecten naar Scheme, aangepast er wordt nu eerst een Deselectie gedaan op de Scheme. - Afhandeling Slepen van Library object naar Project treeview hersteld, logica hersteld naar vorige implementatie. ————————————————————————————————————— ### 7.0.0.4 Uitgebracht op 12-04-2024 #### Toevoegingen - Kopieren van LC_Comments naar Hint veldt aangepast. - Filtering gemaakt voor IO_Type 'WORK' velden. - Filtering gemaakt voor IO_Type 'DI' met Io_index > 1023. - Gefiltered kopieren van hint namen toegevoegd aan het popup menu van de Crossref tabel. - Kopieren van hint namen in het popup menu van de Crossref tabel een confirmatie dialoog gegeven. - In het Tagname selector scherm een checkbox toegevoegd om het automatisch kopieren van hints uit te schakelen. - Fout indicatie in CrossRef en TagNames aangepast. (hierin worden nu voor regels die nog niet compleet zijn rode plaatjes getoont). - Tijdens export in de stap Menus (Step 3) wordt nu een melding gegeven als er geen Menu items ingesteld staan. - Hierin kan nu door de Yes knop te gebruiken een lege uer-menu.txt gemaakt worden. - De Cancel knop stopt de export van user-menu.txt. #### Opgelost - Schemen kwa plaatsing proberen op dezelfde plek te laten openen. - Bij exporteren van BRT bestanden het genereren van de Flag en Mask waardes terug gezet (deze waren stuk in 7.0.0.3). - Scheme upload, na succesvolle upload naar de regelaar wordt er in de bovenbalk een check gezet in de Upload files (Step 4) box. ————————————————————————————————————— ### 7.0.0.3 Uitgebracht op 04-04-2024 #### Toevoegingen - Nieuwe Schemes en Tiles worden aangemaakt met de Background color van het opties menu - Menu balk is aangepast, eerste stap gelijk stelling aan BR Select look and feel - Setup en Tools zijn samengevoegd in Settings - Settings en Help hebben geen Ribbon meer maar een dropdown menu. - Settings bevat de volgende menu's - Hardware Dongle - Options - Properties - BrCad.ini - acExcel - Modules - Citect bitmaps - LogiCad.csv - Help bevat de volgende menu's - About - Help (deze is op het moment leeg) - Menu balk heeft 4 tabbladen (Project, Design, Export en Logging) - Options menu heeft de volgende aanpassingen - In New Document worden de background reset knoppen geupdate zodra er een andere achtergrond kleur wordt geselecteerd - Connection Settings bevat nu de WebUpdate knop (voorheen in de setup ribbon balk) - Connection Settings bevat een plek waar het lokale IP in gesteld kan worden Communicatie tussen BR_Select en BR_Cad - General Settings bevat de Application Style selector. #### Opgelost - Upgrade van RadStudio 11 naar RadStudio 12 - Ombouwen Zip functionaliteit, maken nu gebruik van een andere component - Ombouwen TCP communicatie tussen BR_Select en BR_Cad - Rework van verschillende data grid implementaties zoals Crossref - In het Excel conversions scherm, UI weergave verbeterd, knoppen en teksten toegevoegd ————————————————————————————————————— ### 7.0.0.2 Uitgebracht op 12-03-2024 #### Toevoegingen - Tijdens aanpassen van Crossref velden in het Details segment aanpassen mogelijk maken zoals voor Text en Hint aanpassingen. - Tijdens aanpassen van Velden in de Crossref main tabel, het veld niet kopieren naar een ander object zodra deze geselecteerd wordt in de Scheme weergave. - Bij selecteren van andere Tagname in het Tagname selector scherm wordt nu de LC_Comment ook gezet in het Hint veld. - Hernoemen van Scheme's in de project tree is het nu mogelijk om dezelfde naam te gebruiken met andere hoofd en kleine letters. - Bij het aanmaken van nieuwe Tile's, Scheme's wordt nu de <Regelaar naam>_ voorgesteld als naam voor het nieuwe scheme niet meer de <New sheme name> dit om het aanmaken van nieuwe scheme's te versnellen - Het is nu mogelijk om de achtergrond van Scheme's in te stellen (wordt nu opgeslagen en ingeladen) - In het opties menu zijn drie knoppen toevoegd om het huidige project te kunnen herstellen naar de “new scheme's background color” #### Opgelost - Uploaden van Scheme's naar een BRC45 regelaar gebruikt nu een fixed http poort (80) - Inladen projecten met en Tegel scheme kan verkeerd gaan als de TilePicture niet goed ingevuld is. Dit is gefixed door het image niet verplicht te maken. - Opslaan niet mogelijk na tonen van BRCad.ini via Setup → BrCad.ini knop. Oplossing de Rockey parameter niet resetten als de Rockey logica uit staat. - Automatisch opslaan als er naar Exporteren genavigeerd wordt ————————————————————————————————————— ### 7.0.0.1 Uitgebracht op 26-02-2024 #### Toevoegingen - Bij initieel starten van de applicatie, wordt de applicatie niet meer in volledig gescherm getoond. - Bij herstarten van de applicatie wordt de applicatie terug gezet naar de afmeting en plek van het afsluit moment. - Scheme afmeting is gelimiteerd van 8 x 8 tot 3840 x 2160 (UHD). Als er een te grote waarde in gezet wordt dan wordt de oude waarde terug gezet. - Importeren vanuit Br_Select & Br_TagBuilder werkt via alle manieren (drie op het moment). - Importeren nieuwe plaatjes via Scheme → Popup → Edit Picture (Open image). #### Opgelost - Drie manieren voor BR_Select import. - Menu → Import project from BrSelect. - Project tree → Popup → Import → “Import BrSelect data”. - Project tree → Toolbar → “Import BrSelect data”. - User.ini parameter [OPTIONS] SHIFT_Y heeft een standaard waarde van 20000 in plaats van 16000. - User.ini parameter [OPTIONS} CON_MIN_GAP verwijderd logica voor connectors is uitgeschakeld. - Scheme → Popup → “Find linked IO” optie verwijderd, zat geen logica achter. - TAction check verwijderd uit GetProjectNodes (dit blokkeerde de Import uit BrSelect. - Mad Except parameters aangepast (deze zou nu moeten mailen naar “Ontwikkeling@brcontrols.com” ————————————————————————————————————— ### 7.0.0.0 Uitgebracht op 14-02-2024 #### Toevoegingen - Optimalisatie opstart gedrag applicatie (tijdens laden project / libraries) - Opslaan project dialoog aangepast. - Sluiten project dialoog aangepast. - Open project via Import from BrSelect, sluit het menu na importeren. - Als er geen connectie gemaakt kan worden met BrSelect wordt er een melding getoont. - Masking van Alarm bel gefixed. - AutoAlignment aangepast voor Project en Libraries objecten. - Dupliceren van Alias veld in UserData verwijderd. - Multi copy van LC_TagName naar Alias (in popup menu). - Multi copy van Hint naar Alias (in popup menu). - Select or Change picture Dialoog toegevoegd voor aanpassen plaatjes (Mask color). - Select or Change picture Dialoog shortcuts toegevoegd voor rotate en flip opties (gelijk aan andere rotate en flip shortcuts). - Menu knop aangepast van 'New BrSelect activeNodes' naar 'Import project from BrSelect'. #### Opgelost - Verwijdering van niet benodigde bestanden (in de Installer) - Optimalisatie verwerken images, rotate, flip en edit scherm zijn aangepast voor PictureIdx. - Opstart waarschuwing toegevoegd voor FTP upload (missende OpenSsl folder) - Object toevoegen aan library via popup in treeview werkt weer. - FTP upload wordt standaard op Passive mode gezet (daarna afhankelijk van de User.ini)